你好,歡迎來到IOS教程網

 Ios教程網 >> IOS編程開發 >> IOS開發綜合 >> HDU 3835R(N)(加點思維的暴力枚舉)

HDU 3835R(N)(加點思維的暴力枚舉)

編輯:IOS開發綜合
R(N) Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1637    Accepted Submission(s): 853     Problem Description We know that some positive integer x can be expressed as x=A^2+B^2(A,B are integers). Take x=10 for example,  10=(-3)^2+1^2. We define R(N) (N is positive) to be the total number of variable presentation of N. So R(1)=4, which consists of 1=1^2+0^2, 1=(-1)^2+0^2, 1=0^2+1^2, 1=0^2+(-1)^2.Given N, you are to calculate R(N).     Input No more than 100 test cases. Each case contains only one integer N(N<=10^9).     Output For each N, print R(N) in one line.     Sample Input 2 6 10 25 65     Sample Output 4 0 8 12 16 Hint For the fourth test case, (A,B) can be (0,5), (0,-5), (5,0), (-5,0), (3,4), (3,-4), (-3,4), (-3,-4), (4,3) , (4,-3), (-4,3), (-4,-3)       Source 2011 Multi-University Training Contest 1 - Host by HNU     題目大意:題目意思很好懂,找有多少組a,b可以滿足a^2+b^2==n.n最大是10^9,肯定不可以直接暴力枚舉。那就枚舉a>b>=0,這樣的情況。然後每一種情況會*4。a,b;a,-b;-a,b;-a,-b; 如果b=0的話,5,0;-5,0;0,-5,0,5;也是*4;詳見代碼。   題目地址:R(N)   AC代碼:
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<cmath>
using namespace std;

int main()
{
    int n,i,a,b,ma,res;
    while(~scanf("%d",&n))
    {
        ma=sqrt(double(n));  //最大的a,a>b>=0
        res=0;
        for(a=1;a<=ma;a++)
        {
            b=sqrt(double(n-a*a));
            if(a*a+b*b==n)
                res+=4;  //a,b;a,-b;-a,b;-a,-b;
        }
        cout<<res<<endl;
    }
    return 0;
}

//46MS 280K

 


  1. 上一頁:
  2. 下一頁:
蘋果刷機越獄教程| IOS教程問題解答| IOS技巧綜合| IOS7技巧| IOS8教程
Copyright © Ios教程網 All Rights Reserved